Sierra tries to print a receipt and just stops

I have a new Windows 10 computer that stopped printing to the receipt printer. The printer tries to print, but then stops. The user must restart the printer, reopen the file, and print the receipt again. However, if the user prints the receipt before closing the patron’s record, it will print fine.

I have tried everything I can think of to fix this problem. I have installed a new computer, reinstalled Windows, replaced the printer twice, and installed a new printer. I have also tried different users. Nothing has helped. I am at a loss. If anyone has experienced this problem, please help me find a solution.

So, is it just this one computer that is having the problem? You have other computers with similar configurations that work properly?

What is the printer make/model and the version of the driver are you using? What are you trying to print from Sierra specifically? A CKO receipt?

Hi Wes,

This is only happening on this one computer, but I have also done a complete Windows reinstall. The computer right next to it is all the same down to the hardware with no issues. The Receipt printer is also new out of the box. The current printer is an Epson TM-T88IV receipt. The Driver is EPSON TM-T88IV ReceiptE4 and this printer works with every other app on the computer with no issue, it’s only when printing from Sierra. Anything is Sierra. Chkin chkout, holds, etc… anything in Sierra. It’s a very weird problem and started all of a sudden.


Is it connected with a cable? Have you tried switching the cables between the two machines?

1 Like

Yes, it is connected via USB and I’ve tried different cables and printers.

So, is this the exact same version of the driver as the computer that works? Down to the sub-subversion of the driver? We’ve noted some differences in Epson drivers and there were times when 4.3.15 did NOT work and 4.3.12 DID work.

In our case, the older versions of the driver typically worked better than the newer version.

It looks like all machines are using 4.59.0000. I am looking into downgrading the drivers now. I will report back. Thanks again for all your help.

Ok, I switched the driver out, and no workie. I am going to replace the computer with a new one out of the box. I ll post back.


When we were on Sierra, similar things would sometimes happen to us and what frequently resolved it was setting the receipt printer to be the default printer. We never did figure out why that made a difference, nor did we figure out why it only happened sometimes on some computers. But I’ve learned not to ponder the strangeness of receipt printers overly deeply…

Ok, So I installed a new computer, Changed the network port. Removed the IP phone off of the computer, Installed a new Epson receipt printer and Sierra will print for a little while then just stops, and goes back to the same problem. I am at a loss. My CLS is of no help to me, and because I am part of a consortium, III will not speak to me. Basically, we are screwed with no help. Thanks to everyone that tried to help, it’s more then III or my library system would do