Leap - Country Field Defaulting to Canada

When creating new library cards, we have observed that the default Country is set to Canada. Entering a USA address fails, because it can’t be found in Canada, and setting the country to USA clears any address information entered.

We attempted to suppress the Country field, but due to it being a required field, this caused us to be unable to create library cards.

Is there a way to set the default to USA, or to make the Country field optional so that we can make the process much more smooth?

You might want to check your system AND library/branch level settings in System Administration to see what the default country is:

Once you make the change it might require a restart of the Leap service to make sure the new settings are being pulled in. Or at least a log off/log back on and a refresh of Leap Permissions:


1 Like

Thanks, Wes! I thought there was a way to do it, but wasn’t entirely sure where. I’ll give this a shot.

1 Like

Oddly enough, it does show the Default Country as USA in Administration Explorer - System.

However, when creating new library cards in Leap, it still shows as CANADA

Odd, I wonder if it could be a locale setting on the host operating system of your browser?

I would log a support ticket with Innovative about this. I can see when searching supportal that there appears to be an article on this, but it must be restricted to staff only as there is no article with that title in the search results. This occasionally happens with some support topics.

Let us know if support can unravel this mystery!

Ohh, maybe you need to check these places (at the system/library/branch) at the level:

1 Like

Looks like both of those areas under System, Library, and Branch were all already set to USA. I might need to open that ticket with Innovative