Does Leap create object locks? Has it always?

We’re getting some reports that Leap might not always create object locks for records. We haven’t had time for a lot of testing yet, but I seem to recall that at one point Leap was NOT creating object locks.

  • Does someone else remember Leap not creating object locks? Was it for all record types?
  • Has anyone tried to see what happens when someone logs into the same workstation on the desktop client and on leap?

In my experience, Leap has always created object locks. We see the following locks from Leap:

  • Bibliographic
  • Hold Request
  • Item
  • Patron
  • Patron Status
  • Record Set

I don’t have any record of Leap not creating object locks - our object locks table is usually fairly full on any given day.

As for logging in on the same workstation in the desktop client and Leap - that doesn’t happen very often here but I do this on occasion when troubleshooting something (our front-line staff are on Leap while back-office staff are on the desktop client). I’ve never noticed anything odd and I run into object locks in my own name if I’m not paying attention (which always makes me :person_facepalming:).

Interested in hearing from others because this sounds like a frustrating problem.


Thanks for the feedback @lreynish. I’m thinking that it might have something to do with them logging in after the object lock was established. So, login, establish the lock and then fire up the client or Leap and find the lock isn’t there.

I think part of the login process clears locks, so that may be where the confusion is coming from, but we’re still trying to narrow down the exact steps with them. We’ll let you know what we find out.

Oooh… I can see that. Let me know if you’d like me to test some scenarios.

1 Like